CSC/ECE 517 Fall 2020 - E2070. Refactor response controller.rb

From Expertiza_Wiki
Jump to navigation Jump to search

Project Background

A response is the object that is created when someone fills out a review rubric, such as when one writes a review, gives feedback to a reviewer, or fills out a survey. Responses to the individual rubric items are kept in Answer objects; each Answer object has a response_id to say what Response it is part of. Since response_controller needs to work with many kinds of responses, its code is pretty general. It is not the worst controller in the system, but it would be much clearer if its method names were more descriptive of what they do.

Project Team Member

Chenwei Zhou (czhou6) Tianrui Wang (twang33) Xinran Li (xli56)

Goal of this Project

This project tries to modify and refactor the response_controller.rb in a more clear way

Files Involved

response_controller.rb

response.rb

Issue

Methods need to be fixed

  • def assign_instance_vars
  • def scores
  • def new
  • def set_questionnaire
  • def set_questionnaire_for_new_response
  • def show_calibration_results_for_students

Recommandation from mentor

Project Lists

  • def assign_instance_vars : This name could be more specific.
  • def scores : This should be a model method (in response.rb)! It is all calculation.
  • def new : This method contains a complicated condition that determines whether the submission has been updated since the last time it was reviewed. If it has not, then the reviewer can edit his/her previous review. If there has been an update, then the reviewer gets a new review form to “update” the review. It would make sense to have a model method that tests whether there has been a review since the last file or link was submitted. Then the code here would just call that function. It would be a lot clearer what the new method is doing. set_content(new_response = false) also plays a role in this calculation. Perhaps this method should also be included in the refactoring, for the sake of clarity of the resulting code.
  • def set_questionnaire : Badly named; what kind of questionnaire and why? The name should be a lot clearer.
  • def set_questionnaire_for_new_response : Badly named, no comments, not at all clear. The logic is not like set_questionnaire. Rename, refactor for clarity, and add comments as appropriate.
  • def show_calibration_results_for_student : This method makes about five db accesses. Can it be broken into 2 methods, with the business logic moved to response.rb?

Refactor & Code Modification

def assign_instance_vars

We did the following refactor to make this method more clear

def scores

def set_questionnaire

def show_calibration_results_for_student