User:Ptrived: Difference between revisions
Line 22: | Line 22: | ||
===Changes done as part of refactoring=== | ===Changes done as part of refactoring=== | ||
====Moving variable declaration to right places==== | ====Moving variable declaration to right places==== | ||
There were two variables "msg" and "error_msg" in the create method which were declared and initialized to blank strings and then again assigned some string value before it was used in the method. So we moved the variable declaration to the place were it was used and removed the unnecessary variable declaration. Below if the code snippet for the changes done: | |||
<pre> | |||
Hello | |||
</pre> |
Revision as of 16:44, 23 March 2016
E1614. Refactoring Response Controller
This page provide the details of the changes done as part of the refactoring response controller project(E1614).
A brief overview of Expertiza
Expertiza project is a platform to create reusable learning objects through peer review. It is an open source project which uses Ruby on Rails framework.
Project Statement
The main aim of this project was to refactor the response_controller. The following tasks were completed as part of refactoring in this project:
- Moving variable declaration to right places.
- Removing unused variables.
- Fixing code duplication.
- Replacing if else block with switch statements.
- Remove the unreachable code.
About Response Controller
The Response controller is responsible for the CRUD(Create, Read, Update and Delete) operations on responses. The users can fill out a questionnaire such as review rubric or feedback on the partner's contribution. So the ResponseController handles the various operations on the responses, which are objects that Expertiza creates when you fill out a questionnaire.
Changes done as part of refactoring
Moving variable declaration to right places
There were two variables "msg" and "error_msg" in the create method which were declared and initialized to blank strings and then again assigned some string value before it was used in the method. So we moved the variable declaration to the place were it was used and removed the unnecessary variable declaration. Below if the code snippet for the changes done:
Hello