CSC/ECE 517 Fall 2014/oss E1508 MRS

From Expertiza_Wiki
Revision as of 03:15, 19 March 2015 by Rlcoble (talk | contribs)
Jump to navigation Jump to search

E1508 Refactoring Response Controller

This page provides a description of the Expertiza based OSS project. This project aimed at refactoring the ResponseController.

Problem Statement

Classes involved:

response_controller.rb
response.rb
???????

What they do: Allows the user to create and edit responses to questionnaires … such as performing a review, rating a teammate, or giving feedback to a reviewer.

What's wrong with it:

  • It doesn’t do authorization properly.
  • It contains duplicated methods.
  • Functionality that should be in models is incorporated into the controller.

What needs to be done:

  1. latestresponseversion seems misnamed. It fetches all previous versions of a response (which is to say, all previous review versions by the current reviewer of the current author for the current assignment).
  2. get_scores gets all the scores assigned in a particular response. A “response” is created when someone submits a review, a partner evaluation, a survey, etc.
  3. The rereview method is 98 lines long. Several parts of it should be turned into methods. Sorting review versions is really not a controller responsibility; it would be better to do this in a model class (which class?) Ditto for determining whether a review is current (i.e., was done during the current assignment phase). This is a query that is made about a review (actually, about a response, which may be a review, author feedback, etc.). It should be placed in the appropriate model class.
  4. rereview contains special code to check whether an assignment is “Jen’s assignment”; this was the first assignment we ever created with a multipart rubric. It was hard-coded into the system, rather than working on a rubric that was created in the normal way. It is probably impossible to remove this code without breaking that assignment, but it should be done in a separate method, and commented appropriately as a kludge.
  5. Again in rereview, creating a new version of a review is a model responsibility, and should be moved out of the controller.
  6. There are two (consecutive) copies of the edit method. The second appears to be the newer one, and, according to the rules for method definition, is the one that is currently in use. The first should be removed. Ditto for new_feedback and view--the 2nd version of each appears to be newer & should be kept.
  7. Authorization to perform actions is not checked correctly. It is supposed to be done through the action_allowed? method at the beginning of the class definition. Different authorization should be required for different operations. For example, someone should be allowed to view a response if they wrote the response, or they are the person or on the team whose work the response applied to, or if they are an instructor or TA for the class. The person who wrote a response should be allowed to edit it, but not the person/team who was being reviewed, nor the instructor or TA for the class. Currently, authorization is denied by the redirect_when_disallowed method, which was an earlier, more error-prone way of controlling access. It should go away, now that the class has an action_allowed? method.

Changes Made

Response Controller

Method Name Changes Made Reason For Change
latestResponseVersion Changed name to previous_responses The name wasn't indicative of what the method did
edit Deleted the old edit method The old edit method was not getting called due to ruby rules
new_feedback Deleted the old new_feedback method The old new_feedback method was not getting called due to ruby rules
view Deleted the old view method The old view method was not getting called due to ruby rules
redirect_when_disallowed Moved all of the code from redirect_when_disallowed to action_allowed and changed all of the references Authorization to perform actions wasn't being performed correctly, it is supposed to be done through action_allowed?
action_allowed?

Response Model

Method Name Changes Made Reason For Change